# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(-\s+.*?)^([^-])/$1- $2/gms;t' <<< "24
00:03:01,848 --> 00:03:04,893
- How adorable.
[both laughing]
48
00:02:53,798 --> 00:02:54,758
[clears throat]
49
00:02:57,552 --> 00:02:59,971
- [clears throat] Phil.
What can I get you?"