re = /^(-\s+.*?)^([^-])/m
str = '24
00:03:01,848 --> 00:03:04,893
- How adorable.
[both laughing]
48
00:02:53,798 --> 00:02:54,758
[clears throat]
49
00:02:57,552 --> 00:02:59,971
- [clears throat] Phil.
What can I get you?'
subst = '$1- $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result