const regex = /^(-\s+.*?)^([^-])/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(-\\s+.*?)^([^-])', 'gms')
const str = `24
00:03:01,848 --> 00:03:04,893
- How adorable.
[both laughing]
48
00:02:53,798 --> 00:02:54,758
[clears throat]
49
00:02:57,552 --> 00:02:59,971
- [clears throat] Phil.
What can I get you?`;
const subst = `$1- $2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);