import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(-\\s+.*?)^([^-])";
final String string = "24\n"
+ "00:03:01,848 --> 00:03:04,893\n"
+ "- How adorable.\n"
+ "[both laughing]\n\n"
+ "48\n"
+ "00:02:53,798 --> 00:02:54,758\n"
+ "[clears throat]\n\n"
+ "49\n"
+ "00:02:57,552 --> 00:02:59,971\n"
+ "- [clears throat] Phil.\n"
+ "What can I get you?";
final String subst = "$1- $2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}