using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\([""\\\/bnrt]|u([a-fA-F0-9]{4}))";
string input = @"Bonjour,\nParlez-vous le fran\u00e7ais\u202f?";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}