$re = '/\\\\(["\\\\\/bnrt]|u([a-fA-F0-9]{4}))/';
$str = 'Bonjour,\\nParlez-vous le fran\\u00e7ais\\u202f?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);