// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"\\(["\\\/bnrt]|u([a-fA-F0-9]{4}))"#).unwrap();
let string = "Bonjour,\\nParlez-vous le fran\\u00e7ais\\u202f?";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}