re = /\\(["\\\/bnrt]|u([a-fA-F0-9]{4}))/
str = 'Bonjour,\\nParlez-vous le fran\\u00e7ais\\u202f?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end