using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<protocol>(?:https?:\/\/?)+(?:www(?!.))?)?(?<tdl>[a-zA-Z0-9@:._-]{2,256}\.[a-z0-9]{2,6}(?:[:0-9]{1,5})?)(?<path>(?:\/)[-a-zA-Z0-9\/_]+)?(?<params>[-a-zA-Z0-9?%#+()=&]+)?";
string input = @"http://foo.com/blah_blah
http://foo.com/blah_blah/
https://www.example.com/wpstyle/?p=364
https://www.example.com/wpstyle/wpath/?p=364&?param=this
https://www.example.com/foo/?bar=baz&inga=42&quux
google.com
www.google.com
http://foo.com:
http://foo.com:8080/blah_blah
https://www.example.com/foo/?bar=baz&inga=42&quux
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}