import re
regex = re.compile(r"(?<protocol>(?:https?:\/\/?)+(?:www(?!.))?)?(?<tdl>[a-zA-Z0-9@:._-]{2,256}\.[a-z0-9]{2,6}(?:[:0-9]{1,5})?)(?<path>(?:\/)[-a-zA-Z0-9\/_]+)?(?<params>[-a-zA-Z0-9?%#+()=&]+)?", flags=re.MULTILINE)
test_str = ("http://foo.com/blah_blah\n"
"http://foo.com/blah_blah/\n"
"https://www.example.com/wpstyle/?p=364\n"
"https://www.example.com/wpstyle/wpath/?p=364&?param=this\n"
"https://www.example.com/foo/?bar=baz&inga=42&quux\n"
"google.com\n"
"www.google.com\n"
"http://foo.com:\n"
"http://foo.com:8080/blah_blah\n"
"https://www.example.com/foo/?bar=baz&inga=42&quux\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")