const regex = /(?<protocol>(?:https?:\/\/?)+(?:www(?!.))?)?(?<tdl>[a-zA-Z0-9@:._-]{2,256}\.[a-z0-9]{2,6}(?:[:0-9]{1,5})?)(?<path>(?:\/)[-a-zA-Z0-9\/_]+)?(?<params>[-a-zA-Z0-9?%#+()=&]+)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<protocol>(?:https?:\\\/\\\/?)+(?:www(?!.))?)?(?<tdl>[a-zA-Z0-9@:._-]{2,256}\\.[a-z0-9]{2,6}(?:[:0-9]{1,5})?)(?<path>(?:\\\/)[-a-zA-Z0-9\\\/_]+)?(?<params>[-a-zA-Z0-9?%#+()=&]+)?', 'gm')
const str = `http://foo.com/blah_blah
http://foo.com/blah_blah/
https://www.example.com/wpstyle/?p=364
https://www.example.com/wpstyle/wpath/?p=364&?param=this
https://www.example.com/foo/?bar=baz&inga=42&quux
google.com
www.google.com
http://foo.com:
http://foo.com:8080/blah_blah
https://www.example.com/foo/?bar=baz&inga=42&quux
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}