use strict;
my $str = 'http://foo.com/blah_blah
http://foo.com/blah_blah/
https://www.example.com/wpstyle/?p=364
https://www.example.com/wpstyle/wpath/?p=364&?param=this
https://www.example.com/foo/?bar=baz&inga=42&quux
google.com
www.google.com
http://foo.com:
http://foo.com:8080/blah_blah
https://www.example.com/foo/?bar=baz&inga=42&quux
';
my $regex = qr/(?<protocol>(?:https?:\/\/?)+(?:www(?!.))?)?(?<tdl>[a-zA-Z0-9@:._-]{2,256}\.[a-z0-9]{2,6}(?:[:0-9]{1,5})?)(?<path>(?:\/)[-a-zA-Z0-9\/_]+)?(?<params>[-a-zA-Z0-9?%#+()=&]+)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}