using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\[(\d\d)\:(\d\d)\.(\d\d)\])(?:\[(\d\d)\:(\d\d)\.(\d\d)\])?(?:\[(\d\d)\:(\d\d)\.(\d\d)\])?(?:\[(\d\d)\:(\d\d)\.(\d\d)\])?(.*)";
string input = @"[03:51.91][02:58.48]
[03:13.84][03:09.29][03:04.94][03:00.53]Wait for me to come home
[03:16.13][03:11.70][03:07.19][03:02.75]
[01:32.67]Loving can heal
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}