import re
regex = re.compile(r"(\[(\d\d)\:(\d\d)\.(\d\d)\])(?:\[(\d\d)\:(\d\d)\.(\d\d)\])?(?:\[(\d\d)\:(\d\d)\.(\d\d)\])?(?:\[(\d\d)\:(\d\d)\.(\d\d)\])?(.*)")
test_str = ("[03:51.91][02:58.48]\n"
"[03:13.84][03:09.29][03:04.94][03:00.53]Wait for me to come home\n"
"[03:16.13][03:11.70][03:07.19][03:02.75]\n"
"[01:32.67]Loving can heal\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")