const regex = /(\[(\d\d)\:(\d\d)\.(\d\d)\])(?:\[(\d\d)\:(\d\d)\.(\d\d)\])?(?:\[(\d\d)\:(\d\d)\.(\d\d)\])?(?:\[(\d\d)\:(\d\d)\.(\d\d)\])?(.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\[(\\d\\d)\\:(\\d\\d)\\.(\\d\\d)\\])(?:\\[(\\d\\d)\\:(\\d\\d)\\.(\\d\\d)\\])?(?:\\[(\\d\\d)\\:(\\d\\d)\\.(\\d\\d)\\])?(?:\\[(\\d\\d)\\:(\\d\\d)\\.(\\d\\d)\\])?(.*)', 'g')
const str = `[03:51.91][02:58.48]
[03:13.84][03:09.29][03:04.94][03:00.53]Wait for me to come home
[03:16.13][03:11.70][03:07.19][03:02.75]
[01:32.67]Loving can heal
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}