$re = '/(\[(\d\d)\:(\d\d)\.(\d\d)\])(?:\[(\d\d)\:(\d\d)\.(\d\d)\])?(?:\[(\d\d)\:(\d\d)\.(\d\d)\])?(?:\[(\d\d)\:(\d\d)\.(\d\d)\])?(.*)/';
$str = '[03:51.91][02:58.48]
[03:13.84][03:09.29][03:04.94][03:00.53]Wait for me to come home
[03:16.13][03:11.70][03:07.19][03:02.75]
[01:32.67]Loving can heal
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);