import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\[(\\d\\d)\\:(\\d\\d)\\.(\\d\\d)\\])(?:\\[(\\d\\d)\\:(\\d\\d)\\.(\\d\\d)\\])?(?:\\[(\\d\\d)\\:(\\d\\d)\\.(\\d\\d)\\])?(?:\\[(\\d\\d)\\:(\\d\\d)\\.(\\d\\d)\\])?(.*)";
final String string = "[03:51.91][02:58.48]\n"
+ "[03:13.84][03:09.29][03:04.94][03:00.53]Wait for me to come home\n"
+ "[03:16.13][03:11.70][03:07.19][03:02.75]\n"
+ "[01:32.67]Loving can heal\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}