package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(((0)|([1-9]\d?)|(1\d\d)|(2[0-5]{2}))\.?){0,3}((0)|([1-9]\d?)|(1\d\d)|(2[0-5]{2}))?$`)
var str = `255.255.255.255
192.168.0.1
0.0.0.0
192.168.0.
192.168.0
192.1
0
33.33.33.33
2.2.99
255.255.255.255.
192.168.0.270
0.0.0.a
255.255.255. 255
192.168.0..
0.0.00.0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}