re = /^(((0)|([1-9]\d?)|(1\d\d)|(2[0-5]{2}))\.?){0,3}((0)|([1-9]\d?)|(1\d\d)|(2[0-5]{2}))?$/m
str = '255.255.255.255
192.168.0.1
0.0.0.0
192.168.0.
192.168.0
192.1
0
33.33.33.33
2.2.99
255.255.255.255.
192.168.0.270
0.0.0.a
255.255.255. 255
192.168.0..
0.0.00.0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end