use strict;
my $str = '255.255.255.255
192.168.0.1
0.0.0.0
192.168.0.
192.168.0
192.1
0
33.33.33.33
2.2.99
255.255.255.255.
192.168.0.270
0.0.0.a
255.255.255. 255
192.168.0..
0.0.00.0';
my $regex = qr/^(((0)|([1-9]\d?)|(1\d\d)|(2[0-5]{2}))\.?){0,3}((0)|([1-9]\d?)|(1\d\d)|(2[0-5]{2}))?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}