import re
regex = re.compile(r"^(((0)|([1-9]\d?)|(1\d\d)|(2[0-5]{2}))\.?){0,3}((0)|([1-9]\d?)|(1\d\d)|(2[0-5]{2}))?$", flags=re.MULTILINE)
test_str = ("255.255.255.255\n"
"192.168.0.1\n"
"0.0.0.0\n"
"192.168.0.\n"
"192.168.0\n"
"192.1\n"
"0\n"
"33.33.33.33\n"
"2.2.99\n\n"
"255.255.255.255.\n"
"192.168.0.270\n"
"0.0.0.a\n"
"255.255.255. 255\n"
"192.168.0..\n"
"0.0.00.0")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")