using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:00|\+)[0-9]?()[0-9](\s|\S)(\d[0-9]{6,14})$";
string input = @"+14917672662642";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}