$re = '/^(?:00|\+)[0-9]?()[0-9](\s|\S)(\d[0-9]{6,14})$/';
$str = '+14917672662642';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);