import re
regex = re.compile(r"^(?:00|\+)[0-9]?()[0-9](\s|\S)(\d[0-9]{6,14})$")
test_str = "+14917672662642"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")