const regex = /^(?:00|\+)[0-9]?()[0-9](\s|\S)(\d[0-9]{6,14})$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:00|\\+)[0-9]?()[0-9](\\s|\\S)(\\d[0-9]{6,14})$', '')
const str = `+14917672662642`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}