#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\.\d+\b(*SKIP)(*FAIL)|\d{1,3}(?=(?:\d{3})+(?:\.\d|(?!\S)))"
Local $sString = "1829383839.2937484" & @CRLF & _
"1829383839" & @CRLF & _
"" & @CRLF & _
"test 1829383839 test" & @CRLF & _
"test 1829383839.2937484 test"
Local $sSubst = "$0,"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)