import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\.\\d+\\b(*SKIP)(*FAIL)|\\d{1,3}(?=(?:\\d{3})+(?:\\.\\d|(?!\\S)))";
final String string = "1829383839.2937484\n"
+ "1829383839\n\n"
+ "test 1829383839 test\n"
+ "test 1829383839.2937484 test";
final String subst = "$0,";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}