$re = '/\.\d+\b(*SKIP)(*FAIL)|\d{1,3}(?=(?:\d{3})+(?:\.\d|(?!\S)))/m';
$str = '1829383839.2937484
1829383839
test 1829383839 test
test 1829383839.2937484 test';
$subst = "$0,";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;