const regex = /\.\d+\b(*SKIP)(*FAIL)|\d{1,3}(?=(?:\d{3})+(?:\.\d|(?!\S)))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.\\d+\\b(*SKIP)(*FAIL)|\\d{1,3}(?=(?:\\d{3})+(?:\\.\\d|(?!\\S)))', 'gm')
const str = `1829383839.2937484
1829383839
test 1829383839 test
test 1829383839.2937484 test`;
const subst = `$0,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);