import Foundation
let pattern = #"\.\d+\b(*SKIP)(*FAIL)|\d{1,3}(?=(?:\d{3})+(?:\.\d|(?!\S)))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1829383839.2937484
1829383839
test 1829383839 test
test 1829383839.2937484 test
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$0,"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)