import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=<li><a>)[\\u0400-\\u04FF]{1,}_";
final String string = "<div class=\"brd\">\n"
+ " <ul class=\"brd-navigation\">\n"
+ " <li><a>Текст</a></li>\n"
+ " <li><a>Текст</a></li>\n"
+ " <li><a>Текст</a></li>\n"
+ " <li><a>Текст_</a></li>\n"
+ " <li><a>Текст</a></li>\n"
+ " </ul>\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}