$re = '/(?<=<li><a>)[\u0400-\u04FF]{1,}_/m';
$str = '<div class="brd">
<ul class="brd-navigation">
<li><a>Текст</a></li>
<li><a>Текст</a></li>
<li><a>Текст</a></li>
<li><a>Текст_</a></li>
<li><a>Текст</a></li>
</ul>
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);