const regex = /(?<=<li><a>)[\u0400-\u04FF]{1,}_/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=<li><a>)[\\u0400-\\u04FF]{1,}_', 'gm')
const str = `<div class="brd">
<ul class="brd-navigation">
<li><a>Текст</a></li>
<li><a>Текст</a></li>
<li><a>Текст</a></li>
<li><a>Текст_</a></li>
<li><a>Текст</a></li>
</ul>
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}