#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=-)(?(?=\d{2})|(?'oneLetter'\d))(?=\D)"
Local $sString = "2020-7-3; blah.mp4" & @CRLF & _
"2022-08-03_blah.mp4" & @CRLF & _
"2013-04-03-20-34-08; blah.mp4"
Local $sSubst = "0$oneLetter"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)