import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=-)(?(?=\\d{2})|(?'oneLetter'\\d))(?=\\D)";
final String string = "2020-7-3; blah.mp4\n"
+ "2022-08-03_blah.mp4\n"
+ "2013-04-03-20-34-08; blah.mp4";
final String subst = "0$oneLetter";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}