re = /(?<=-)(?(?=\d{2})|(?'oneLetter'\d))(?=\D)/m
str = '2020-7-3; blah.mp4
2022-08-03_blah.mp4
2013-04-03-20-34-08; blah.mp4'
subst = '0$oneLetter'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result