# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=-)(?(?=\d{2})|(?'oneLetter'\d))(?=\D)"
test_str = ("2020-7-3; blah.mp4\n"
"2022-08-03_blah.mp4\n"
"2013-04-03-20-34-08; blah.mp4")
subst = "0$oneLetter"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.