#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=\w{6}).*\d\d"
Local $sString = "bana12" & @CRLF & _
"abc123" & @CRLF & _
"" & @CRLF & _
"banan1" & @CRLF & _
"airplanes" & @CRLF & _
"astronaut" & @CRLF & _
"123" & @CRLF & _
"1234" & @CRLF & _
"" & @CRLF & _
"ab1c23"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")