const regex = /^(?=\w{6}).*\d\d/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=\\w{6}).*\\d\\d', 'gm')
const str = `bana12
abc123
banan1
airplanes
astronaut
123
1234
ab1c23`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}