import re
regex = re.compile(r"^(?=\w{6}).*\d\d", flags=re.MULTILINE)
test_str = ("bana12\n"
"abc123\n\n"
"banan1\n"
"airplanes\n"
"astronaut\n"
"123\n"
"1234\n\n"
"ab1c23")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")