import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=\\w{6}).*\\d\\d";
final String string = "bana12\n"
+ "abc123\n\n"
+ "banan1\n"
+ "airplanes\n"
+ "astronaut\n"
+ "123\n"
+ "1234\n\n"
+ "ab1c23";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}