package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[^#]*#{1})(name=.*?z\d*)$`)
var str = `https://mywebsite.com/myPets/localPets#name=testz0
https://mywebsite.com/myPets/localPets#name=test
https://mywebsite.com/myPets/localPets#name=testz999
https://mywebsite.com/myPets/localPets#=testz0
https://mywebsite.com#/myPets/localPets#name=testz0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}