re = /^(?:[^#]*#{1})(name=.*?z\d*)$/m
str = 'https://mywebsite.com/myPets/localPets#name=testz0
https://mywebsite.com/myPets/localPets#name=test
https://mywebsite.com/myPets/localPets#name=testz999
https://mywebsite.com/myPets/localPets#=testz0
https://mywebsite.com#/myPets/localPets#name=testz0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end