const regex = /^(?:[^#]*#{1})(name=.*?z\d*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[^#]*#{1})(name=.*?z\\d*)$', 'gm')
const str = `https://mywebsite.com/myPets/localPets#name=testz0
https://mywebsite.com/myPets/localPets#name=test
https://mywebsite.com/myPets/localPets#name=testz999
https://mywebsite.com/myPets/localPets#=testz0
https://mywebsite.com#/myPets/localPets#name=testz0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}