import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[^#]*#{1})(name=.*?z\\d*)$";
final String string = "https://mywebsite.com/myPets/localPets#name=testz0\n"
+ "https://mywebsite.com/myPets/localPets#name=test\n"
+ "https://mywebsite.com/myPets/localPets#name=testz999\n"
+ "https://mywebsite.com/myPets/localPets#=testz0\n"
+ "https://mywebsite.com#/myPets/localPets#name=testz0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}