$re = '/^(?:[^#]*#{1})(name=.*?z\d*)$/m';
$str = 'https://mywebsite.com/myPets/localPets#name=testz0
https://mywebsite.com/myPets/localPets#name=test
https://mywebsite.com/myPets/localPets#name=testz999
https://mywebsite.com/myPets/localPets#=testz0
https://mywebsite.com#/myPets/localPets#name=testz0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);