#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^„(.*)“[\r\n]*Auszug aus: (.*)\. „(.*)\.“ iBooks.$"
Local $sString = "„Das ist ein Test.“" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Auszug aus: Neil DeGrasse Tyson. „Astrophysics for People in a Hurry.“ iBooks."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")