using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^„(.*)“[\r\n]*Auszug aus: (.*)\. „(.*)\.“ iBooks.$";
string input = @"„Das ist ein Test.“
Auszug aus: Neil DeGrasse Tyson. „Astrophysics for People in a Hurry.“ iBooks.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}