re = /^„(.*)“[\r\n]*Auszug aus: (.*)\. „(.*)\.“ iBooks.$/m
str = '„Das ist ein Test.“
Auszug aus: Neil DeGrasse Tyson. „Astrophysics for People in a Hurry.“ iBooks.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end