$re = '/^„(.*)“[\r\n]*Auszug aus: (.*)\. „(.*)\.“ iBooks.$/m';
$str = '„Das ist ein Test.“
Auszug aus: Neil DeGrasse Tyson. „Astrophysics for People in a Hurry.“ iBooks.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);